03 speed triple no start

gasgas

Member
Local time
Today, 14:14
Joined
Oct 11, 2013
Messages
8
Points
5
Location
Summit Hill
First Name
Rich
My Ride
00 Triumph 900 trophy
I just picked up an 03 speed triple and was not running at purchase. All lights, turn signals and brake light work and new battery installed and all fuses were checked. With key on I get nothing from starter not even a click and odometer will not light up. anyone have a clue. thanks
 

devo

hairy old fart
Local time
Tomorrow, 08:14
Joined
Aug 21, 2007
Messages
5,371
Points
567
Location
Paraparaumu
First Name
Harry
My Ride
07 America
OK,So I dont know the layout on the triples so excuse me if I'm of base, but, I am presuming there will be a relay between the starter swtch and the starter. If this is shot,it will not crank.
As for speedo light,It could be related or it could be a seperate issue such as connections or a bulb.
You can by pass the starter relay with a jab from a jumper cable to pin point the problem.Just locate the big + terminal at the starter motor and touch it with 12 volts.

EDIT : Thinking on this,before you look anywhere else,check the KILL switch.
I never use it so tend to forget about it untill someone else has fiddled with my bike.
 

gasgas

Member
Local time
Today, 14:14
Joined
Oct 11, 2013
Messages
8
Points
5
Location
Summit Hill
First Name
Rich
My Ride
00 Triumph 900 trophy
devo thanks for the reply. I checked all the relays and jumpered the starter solinoid, the bike cranked but would not fire up. The fuel pump is not getting power either and my neutral light won't come on. I need a wire diagram to see what wires feed everything
 

devo

hairy old fart
Local time
Tomorrow, 08:14
Joined
Aug 21, 2007
Messages
5,371
Points
567
Location
Paraparaumu
First Name
Harry
My Ride
07 America
Did you catch my edit re the kill switch.?
 

The Seeker

Thunderbird
Local time
Today, 14:14
Joined
Mar 5, 2006
Messages
8,473
Points
771
Location
Pittsburgh, Pennsylvania, USA
First Name
AJ Turner
My Ride
1996 Triumph Trophy 1200
The fact that the neutral light doesn't come on may be key.

Perhaps the bike thinks it's in gear and requires the clutch to be pulled-in?

In the starter circuit there is a clutch switch, a kill switch, and a side stand switch. If the side stand is down, you can't start the bike.

Try starting it with the stand up, the kill switch set to run, and the clutch lever pulled in.

-- Posted with TapaTalk
 

gasgas

Member
Local time
Today, 14:14
Joined
Oct 11, 2013
Messages
8
Points
5
Location
Summit Hill
First Name
Rich
My Ride
00 Triumph 900 trophy
Did you catch my edit re the kill switch.?
Yep, it was the first thing I checked. I found two plugs hanging under the gas tank and I think one two wire plug goe's to the ECU and the other is for the fan but with out a wire diagram I am not positive, I guess I'll have to wait till I get the manual to make sure. thanks
 

gasgas

Member
Local time
Today, 14:14
Joined
Oct 11, 2013
Messages
8
Points
5
Location
Summit Hill
First Name
Rich
My Ride
00 Triumph 900 trophy
I tried that also,but it seems like no power to ECU
 

avion

Android Guru
Local time
Today, 21:14
Joined
Jun 29, 2007
Messages
1,862
Points
192
Location
East Rand
First Name
Gareth / G
My Ride
Tiger 800 2011
sounds like electrical

check the harness for obvious damage.

hth



Sent from my GT-N7100 using Tapatalk
 

gasgas

Member
Local time
Today, 14:14
Joined
Oct 11, 2013
Messages
8
Points
5
Location
Summit Hill
First Name
Rich
My Ride
00 Triumph 900 trophy
Well I found the problem. I disconnected the battery to pull the solenoid out and left it disconnected over night, the next day i hooked up the battery and turned on the key and BAM I had all the electronics working, put up the kick stand, pulled in the clutch and it started right up, took it for a short ride and is working perfectly. Thanks for all your help. I guess the computer had to reset, the only thing I noticed was that the speedometer was showing only first digit numbers like 1 at 10mph and 2 for 20 mph but I can live with that.
 

devo

hairy old fart
Local time
Tomorrow, 08:14
Joined
Aug 21, 2007
Messages
5,371
Points
567
Location
Paraparaumu
First Name
Harry
My Ride
07 America
Great stuff,must admit,I never would have thought of it.
 

CarlS

Charter Member #3
Riding for 64 Years
Staff
Local time
Today, 14:14
Joined
Jan 5, 2006
Messages
28,988
Points
1,218
Age
78
Location
Dania Beach, Florida
First Name
Carl
My Ride
12 Tiger 800 XC
Thanks for reporting back. I guess the reset did it. I would not have thought of that either.
 

avion

Android Guru
Local time
Today, 21:14
Joined
Jun 29, 2007
Messages
1,862
Points
192
Location
East Rand
First Name
Gareth / G
My Ride
Tiger 800 2011
wierd, glad it's sorted though.

...

Sent from my GT-N7100 using Tapatalk
 
Premium

Support TriumphTalk by becoming a Premium Member.

 What You Get

Donate

 

 

Search

Top Bottom