2007 Daytona Triumph Help

dustin 123

Member
Local time
Today, 11:07
Joined
Apr 30, 2016
Messages
13
Points
5
Age
29
Location
united states
First Name
dustin
My Ride
2007 daytona triumph
Okay so having some problems 28th my bike it was wrecked a couple years ago by a buddy of mine it got the front barometric sensor up front and that's about all beside fairings and broke tabs off the cluster so here's what it's doing I start try to start it and it take a a minute to start then it does and it sounds fine at idle then you try and hammer on it and it just dies out and if you twist it slow it won't go past 8500 rpm I have tryed new gas new air filter new r/r checked for loose wires and it throws a these codes p1698 sensor supply batterie circuit malfunction
P1107 ambient sensor circuit low voltage or short to ground
P0122 throttle position sensor low voltage short to ground or open circuit
And I hook it to tuneecu and try to delete them and they come right back up I can not figure it out please help
 

Rocky

Still Rocking
Riding for 27 Years
Administrator
Staff
Local time
Today, 14:07
Joined
Jan 28, 2006
Messages
17,690
Points
893
Age
82
Location
Halifax
First Name
Rocky
My Ride
2006 T100 Bonneville
Sorry, this is beyond me.
I hope somebody else can help out.
 

shanered6

Time for adventure
Riding for 43 Years
Staff
Local time
Today, 18:07
Joined
Apr 5, 2011
Messages
6,157
Points
523
Age
51
Location
Turriff, Aberdeenshire
First Name
shane llywarch
My Ride
Moto Guzzi Stelvio 1200 ntx
The problems are in the headlights wiring circuit that's were most of the wiring is , check the loom has not been crushed or pinched in the steering locks .
Then check for bare wires or bad grounds in the connectors .
 

dustin 123

Member
Local time
Today, 11:07
Joined
Apr 30, 2016
Messages
13
Points
5
Age
29
Location
united states
First Name
dustin
My Ride
2007 daytona triumph
Okay yea it ruined the head light so I don't even have that plugged in and forgot to mention I ordered a used wire harness and after the wreck cause the other one was a little scuffed up could it be the ecu cause it is very consistent with the no rev past 8500 ?
 

shanered6

Time for adventure
Riding for 43 Years
Staff
Local time
Today, 18:07
Joined
Apr 5, 2011
Messages
6,157
Points
523
Age
51
Location
Turriff, Aberdeenshire
First Name
shane llywarch
My Ride
Moto Guzzi Stelvio 1200 ntx
Is the engine light on ?
 

dustin 123

Member
Local time
Today, 11:07
Joined
Apr 30, 2016
Messages
13
Points
5
Age
29
Location
united states
First Name
dustin
My Ride
2007 daytona triumph
Yea the check engine light is on and the codes are up above every time I delete them the immediately come right back
 

dustin 123

Member
Local time
Today, 11:07
Joined
Apr 30, 2016
Messages
13
Points
5
Age
29
Location
united states
First Name
dustin
My Ride
2007 daytona triumph
Should also mention has a brand new batt holds 14.3 volts new plugs exup has been removed sai has been removed I'm tune ecu I have tryed to upload a new map on it even and it does the same thing I am miles and miles away from anyone who works on them so I'm all on my own I have learned a lot about this bike just on these forums and really hope you guys can help me with it
 

shanered6

Time for adventure
Riding for 43 Years
Staff
Local time
Today, 18:07
Joined
Apr 5, 2011
Messages
6,157
Points
523
Age
51
Location
Turriff, Aberdeenshire
First Name
shane llywarch
My Ride
Moto Guzzi Stelvio 1200 ntx
It could be in limp mode due to the short in the wiring !
 

dustin 123

Member
Local time
Today, 11:07
Joined
Apr 30, 2016
Messages
13
Points
5
Age
29
Location
united states
First Name
dustin
My Ride
2007 daytona triumph
Alright well I will double check it all and few other questions I have I don't have a manual for it and I need to find out the tourqe sequence for the cam and cam cover I can't seem to find those at all
 

shanered6

Time for adventure
Riding for 43 Years
Staff
Local time
Today, 18:07
Joined
Apr 5, 2011
Messages
6,157
Points
523
Age
51
Location
Turriff, Aberdeenshire
First Name
shane llywarch
My Ride
Moto Guzzi Stelvio 1200 ntx
I don't no them but I usually find around 20 to 25 flb is enough to seal it and dosnt over tighten , but you can do it by feel just don't go mad !
 

dustin 123

Member
Local time
Today, 11:07
Joined
Apr 30, 2016
Messages
13
Points
5
Age
29
Location
united states
First Name
dustin
My Ride
2007 daytona triumph
Is there a certain order You have to tq them in just like when you tq the head back on ?
 

shanered6

Time for adventure
Riding for 43 Years
Staff
Local time
Today, 18:07
Joined
Apr 5, 2011
Messages
6,157
Points
523
Age
51
Location
Turriff, Aberdeenshire
First Name
shane llywarch
My Ride
Moto Guzzi Stelvio 1200 ntx
Usually you start in the middle doing opposites and work your way out .
 

shanered6

Time for adventure
Riding for 43 Years
Staff
Local time
Today, 18:07
Joined
Apr 5, 2011
Messages
6,157
Points
523
Age
51
Location
Turriff, Aberdeenshire
First Name
shane llywarch
My Ride
Moto Guzzi Stelvio 1200 ntx
Oh and just nip them up first then tighten them up properly after .
 

dustin 123

Member
Local time
Today, 11:07
Joined
Apr 30, 2016
Messages
13
Points
5
Age
29
Location
united states
First Name
dustin
My Ride
2007 daytona triumph
Okay I will give it a shot when the gasket comes in
 

shanered6

Time for adventure
Riding for 43 Years
Staff
Local time
Today, 18:07
Joined
Apr 5, 2011
Messages
6,157
Points
523
Age
51
Location
Turriff, Aberdeenshire
First Name
shane llywarch
My Ride
Moto Guzzi Stelvio 1200 ntx
Let us know how you get on (y)
 

dustin 123

Member
Local time
Today, 11:07
Joined
Apr 30, 2016
Messages
13
Points
5
Age
29
Location
united states
First Name
dustin
My Ride
2007 daytona triumph
Maybe you guys can help me with a good tune for it also ex system is stock I cut cat open and removed that and welded it back on two brothers slip on no exup no sia servo and I want to run 91 octain fuel in it cant seem to find a decent tune for it
 
Premium

Support TriumphTalk by becoming a Premium Member.

 What You Get

Donate

 

 

Top Bottom