Advice needed

TTTrophy900

Member
Riding for 30 Years
Local time
Today, 20:13
Joined
Aug 31, 2019
Messages
4
Points
0
Age
56
Location
Australia
First Name
Tony
My Ride
Triumph 2001 Trophy
Greetings from Australia. I have a 2001 900 Trophy recently purchased with 45000km.It has a new battery fitted & been serviced.Purchased 2 weeks ago as a 2nd bike to play around with.Have only ridden it for short distances until today.Full tank of fuel & bike riding well until around 60km of travel in 5th gear the bike started to run very rough as though starved for fuel or misfiring & tacho was erratic.Changed down a gear & improved, then it cut out.Pulled over &
could not restart the bike & battery seemed to be low on charge as the horn had no volume & headlight dulling.Ended up bringing bike back in the work van.Not sure of problem, battery is less than a week old & first use.Could it be one of the coils or the pickup sensor coil.Or possibly the battery wasnt charging while riding.Could not be restarted even after cooling down as though it had a flat battery.Have not tested voltage etc as yet.Anybody else out there had similar issues or symptons.Cheers
 

CarlS

Big Kahuna
Riding for 61 Years
Staff
Local time
Today, 15:13
Joined
Jan 5, 2006
Messages
26,374
Points
1,068
Age
75
Location
Altamonte Springs, Florida
First Name
Carl
My Ride
12 Tiger 800 XC
Sounds to me that your battery was not charging while you were riding or the battery shorted out internally. I had the latter happen to me with my Tiger. Same symptoms.
 

Greyfell

Proud Nerd
Riding for 2 Years
Local time
Today, 12:13
Joined
May 4, 2016
Messages
1,807
Points
152
Age
63
Location
Northern California
First Name
Stephen
My Ride
2008 Triumph Bonneville T100 Ann-Margret
Yes, as "rare" as it is, it is as CarlS said. The battery shorted out internally. Sorry, it is unlikely you can return it for your money back or a replacement, but don't let what I said stop you from trying.
 

TTTrophy900

Member
Riding for 30 Years
Local time
Today, 20:13
Joined
Aug 31, 2019
Messages
4
Points
0
Age
56
Location
Australia
First Name
Tony
My Ride
Triumph 2001 Trophy
Sounds to me that your battery was not charging while you were riding or the battery shorted out internally. I had the latter happen to me with my Tiger. Same symptoms.
Thanks I will check if it is charging when engine is running & confirm if battery has shorted.
 

TTTrophy900

Member
Riding for 30 Years
Local time
Today, 20:13
Joined
Aug 31, 2019
Messages
4
Points
0
Age
56
Location
Australia
First Name
Tony
My Ride
Triumph 2001 Trophy
Yes, as "rare" as it is, it is as CarlS said. The battery shorted out internally. Sorry, it is unlikely you can return it for your money back or a replacement, but don't let what I said stop you from trying.
See how I go.Will confirm if its not a charging problem
 

Gogreen

Member
Riding for 46 Years
Local time
Today, 20:13
Joined
Jul 2, 2015
Messages
40
Points
7
Location
UK
First Name
Phil
My Ride
Thunderbird Sport; T140D
Be very careful when dealing with charging problems as attempting to start a T300 series bike with a marginal battery can damage the sprag clutch and thats not good.
 
Premium

Support TriumphTalk by becoming a Premium Member.

 What You Get

Donate

 

 

Top Bottom