Heated Seat Quit After Connectivity System Fitted.

Zuki1

Member
Local time
Today, 07:29
Joined
Apr 15, 2021
Messages
14
Points
7
Age
49
Location
PNW
My Ride
Tiger 800 XCA
So I had the bluetooth module fitted to my 2018 Tiger 800 XCA and the heated seat quit working after the software update. The passenger heated seat still works! My dealer now has a case open with Triumph UK as the support in the US could not figure it out. They have had the bike for a few weeks now!

The indicator will just turn grey and I can hear the relay do what sounds like a double click.

They have checked relays, wiring, the seat itself...nothing.

Larry
 

Greyfell

Proud Nerd
Riding for 4 Years
Local time
Today, 07:29
Joined
May 4, 2016
Messages
3,072
Points
377
Age
65
Location
Northern California
First Name
Stephen
My Ride
2008 Triumph Bonneville T100 Ann-Margret
That's strange, and that's why the dealer went to the specialists at the HQ. Let us know what you learn, please.
 

Zuki1

Member
Local time
Today, 07:29
Joined
Apr 15, 2021
Messages
14
Points
7
Age
49
Location
PNW
My Ride
Tiger 800 XCA
That's strange, and that's why the dealer went to the specialists at the HQ. Let us know what you learn, please.
I spoke with Triumph and they have now pushed the case to the electrical engineering team. They say they have received reports of this happening in other parts of the world. I guess they don't have a fix yet.
 

Greyfell

Proud Nerd
Riding for 4 Years
Local time
Today, 07:29
Joined
May 4, 2016
Messages
3,072
Points
377
Age
65
Location
Northern California
First Name
Stephen
My Ride
2008 Triumph Bonneville T100 Ann-Margret
You and the dealer have probably checked this, but does your seat have a separate fuse that might be blown?
 

Charlie1780

Member
Riding for 44 Years
Local time
Today, 15:29
Joined
May 13, 2021
Messages
38
Points
7
Age
57
Location
Cannock, UK
First Name
Stewart
My Ride
Tiger 800
Scrambler 1200XE
I have spoken to the dealer, its a known problem but they are working on an update. Problem is your bike will need to go to the dealer to be updated, it cant be done through the app which is a shame.
As of today the update isn't ready.
 

Zuki1

Member
Local time
Today, 07:29
Joined
Apr 15, 2021
Messages
14
Points
7
Age
49
Location
PNW
My Ride
Tiger 800 XCA
I have spoken to the dealer, its a known problem but they are working on an update. Problem is your bike will need to go to the dealer to be updated, it cant be done through the app which is a shame.
As of today the update isn't ready.
Thanks. Yes, I just heard from my dealer today. Sure hope it gets fixed soon as it also broke the fuel gauge which is also a known issue. They say the issues are only with the Tiger. I sure don't like to pay to become a software tester! :cry:
 

buddyrm

Member
Riding for 31 Years
Local time
Today, 10:29
Joined
May 28, 2021
Messages
25
Points
7
Age
63
Location
Montreal
My Ride
Tiger 800 2018
Thanks. Yes, I just heard from my dealer today. Sure hope it gets fixed soon as it also broke the fuel gauge which is also a known issue. They say the issues are only with the Tiger. I sure don't like to pay to become a software tester! :cry:
My wife and I have each a 2018 tiger 800 and had the bluetooth system installed and we too have lost our heated seats, :-( I waited 24 months for this kit and now after installing it, the heated seats are broken, I would be very surprised if Triumph actually fixes this in the next few months, their track record is not very good. I too contact Triumph USA and issued a complaint. Lets see how it goes. I will also post if I hear any updates.
 

buddyrm

Member
Riding for 31 Years
Local time
Today, 10:29
Joined
May 28, 2021
Messages
25
Points
7
Age
63
Location
Montreal
My Ride
Tiger 800 2018
Thanks. Yes, I just heard from my dealer today. Sure hope it gets fixed soon as it also broke the fuel gauge which is also a known issue. They say the issues are only with the Tiger. I sure don't like to pay to become a software tester! :cry:
I have the issue with the heated seat after the update, but I am not sure I understand about the fuel issue you mentioned. I see not problem after the update. Can you elaborate exactly what is the issue with the fuel gauge?
 

Zuki1

Member
Local time
Today, 07:29
Joined
Apr 15, 2021
Messages
14
Points
7
Age
49
Location
PNW
My Ride
Tiger 800 XCA
I have the issue with the heated seat after the update, but I am not sure I understand about the fuel issue you mentioned. I see not problem after the update. Can you elaborate exactly what is the issue with the fuel gauge?
When I fill the tank completely, the gauge will not register anything. After I ride for a while, enough to where the gauge would drop down a bar, it will reappear. Very strange.
 

Zuki1

Member
Local time
Today, 07:29
Joined
Apr 15, 2021
Messages
14
Points
7
Age
49
Location
PNW
My Ride
Tiger 800 XCA
Well, there wasn't a software update in June and now my dealer is telling me that Triumph is hoping for August! I don't need the heated seat now, but it would be nice to have the bluetooth functionality I paid for as well as a fuel gauge that works all the time. When I try and contact Triumph directly, they don't have much much to say..
 

buddyrm

Member
Riding for 31 Years
Local time
Today, 10:29
Joined
May 28, 2021
Messages
25
Points
7
Age
63
Location
Montreal
My Ride
Tiger 800 2018
Well, there wasn't a software update in June and now my dealer is telling me that Triumph is hoping for August! I don't need the heated seat now, but it would be nice to have the bluetooth functionality I paid for as well as a fuel gauge that works all the time. When I try and contact Triumph directly, they don't have much much to say..
Well confirmed, both my 2018 tigers show zero fuel on the gauge at fill-up and it takes about 65km to start showing a reading of full minus one bar. Pretty sad how bad the software update is. I advised triumph USA. They said a fix should be out August. So unacceptable this software, must have been done in India. Or China. Zero quality control and testing.
 

Zuki1

Member
Local time
Today, 07:29
Joined
Apr 15, 2021
Messages
14
Points
7
Age
49
Location
PNW
My Ride
Tiger 800 XCA
Well confirmed, both my 2018 tigers show zero fuel on the gauge at fill-up and it takes about 65km to start showing a reading of full minus one bar. Pretty sad how bad the software update is. I advised triumph USA. They said a fix should be out August. So unacceptable this software, must have been done in India. Or China. Zero quality control and testing.
Thanks for confirming, as sad as it is. Triumph tried to tell me that the fuel gauge issue was not related to the update and that it had to be an issue with my bike....My dealer said that is what they were told as well, but they said it was too much of a coincidence....
 

buddyrm

Member
Riding for 31 Years
Local time
Today, 10:29
Joined
May 28, 2021
Messages
25
Points
7
Age
63
Location
Montreal
My Ride
Tiger 800 2018
Thanks for confirming, as sad as it is. Triumph tried to tell me that the fuel gauge issue was not related to the update and that it had to be an issue with my bike....My dealer said that is what they were told as well, but they said it was too much of a coincidence....
I have forwarded a detailed report with photos proving that this is software related. I also included other small issues after the update. In general this update is horrible. I was assured that the report was sent to Triumph engineering and will be looked at. Otherwise I asked them to put back the original software if it is not corrected by august and I will send them back their Bluetooth module. It's not worth it. Waste of money. All this after waiting over 2 years for this module. Not impressed with Triumph. My last triumph for sure. Unprofessional.
 

sikatri

Well-Known Member
Local time
Today, 09:29
Joined
May 25, 2019
Messages
1,213
Points
122
Age
61
Location
Houston
My Ride
2005 Triumph Thruxton 900
Can the update be uninstalled and set to a previous working one?
 

Zuki1

Member
Local time
Today, 07:29
Joined
Apr 15, 2021
Messages
14
Points
7
Age
49
Location
PNW
My Ride
Tiger 800 XCA
Can the update be uninstalled and set to a previous working one?
Not from what my dealer said. They had my bike for a month and they tried to revert back to the original software and it was still broken.
 

Zuki1

Member
Local time
Today, 07:29
Joined
Apr 15, 2021
Messages
14
Points
7
Age
49
Location
PNW
My Ride
Tiger 800 XCA
I have forwarded a detailed report with photos proving that this is software related. I also included other small issues after the update. In general this update is horrible. I was assured that the report was sent to Triumph engineering and will be looked at. Otherwise I asked them to put back the original software if it is not corrected by august and I will send them back their Bluetooth module. It's not worth it. Waste of money. All this after waiting over 2 years for this module. Not impressed with Triumph. My last triumph for sure. Unprofessional.
Yep, my first and last Triumph. Sad, as I actually like the bike. I also have a 12 year old Ural Patrol, and I get better support from Ural!
 

buddyrm

Member
Riding for 31 Years
Local time
Today, 10:29
Joined
May 28, 2021
Messages
25
Points
7
Age
63
Location
Montreal
My Ride
Tiger 800 2018
Yep, my first and last Triumph. Sad, as I actually like the bike. I also have a 12 year old Ural Patrol, and I get better support from Ural!
Sad indeed. It's now August 13th and still no word on a fix from Triumph. I have just about given up since it was first reported back in April. Truly sad at the level of support from Triumph. I am asking Triumph to revert my software update back and will be sending the Bluetooth modules back to them. Just not worth it with all the issues.
 

Vector

Well-Known Member
Riding for 51 Years
Local time
Today, 07:29
Joined
Apr 10, 2020
Messages
331
Points
77
Location
NV
First Name
Gary
My Ride
2020 Vanderhall Venice Blackjack
I had a 2012 ST it had software issues. The bike would lose power and shut down, I was almost hit twice. Triumph said a fault that was displayed "was not in the software and not possible" I was able to grab my cell-camera after a shut down, took a pic of the screen display and sent it along with a letter from my attorney. Triumph fully refunded my purchase.
 

sikatri

Well-Known Member
Local time
Today, 09:29
Joined
May 25, 2019
Messages
1,213
Points
122
Age
61
Location
Houston
My Ride
2005 Triumph Thruxton 900
I had a 2012 ST it had software issues. The bike would lose power and shut down, I was almost hit twice. Triumph said a fault that was displayed "was not in the software and not possible" I was able to grab my cell-camera after a shut down, took a pic of the screen display and sent it along with a letter from my attorney. Triumph fully refunded my purchase.
A huge reason I like the simpler models, computer issues are things I don’t care to deal with. I hate updates even on phones. There’s always something that goes wrong.
 

Zuki1

Member
Local time
Today, 07:29
Joined
Apr 15, 2021
Messages
14
Points
7
Age
49
Location
PNW
My Ride
Tiger 800 XCA
Sad indeed. It's now August 13th and still no word on a fix from Triumph. I have just about given up since it was first reported back in April. Truly sad at the level of support from Triumph. I am asking Triumph to revert my software update back and will be sending the Bluetooth modules back to them. Just not worth it with all the issues.
Please let me know if they can revert the software as my dealer said they tried and it failed.
 
Premium

Support TriumphTalk by becoming a Premium Member.

 What You Get

Donate

 

 

Search

Top Bottom