Heated Seat Quit After Connectivity System Fitted.

Zuki1

Member
Local time
Yesterday, 16:26
Joined
Apr 15, 2021
Messages
4
Points
0
Age
49
Location
PNW
My Ride
Tiger 800 XCA
So I had the bluetooth module fitted to my 2018 Tiger 800 XCA and the heated seat quit working after the software update. The passenger heated seat still works! My dealer now has a case open with Triumph UK as the support in the US could not figure it out. They have had the bike for a few weeks now!

The indicator will just turn grey and I can hear the relay do what sounds like a double click.

They have checked relays, wiring, the seat itself...nothing.

Larry
 

Greyfell

Proud Nerd
Riding for 4 Years
Local time
Yesterday, 16:26
Joined
May 4, 2016
Messages
2,799
Points
292
Age
64
Location
Northern California
First Name
Stephen
My Ride
2008 Triumph Bonneville T100 Ann-Margret
That's strange, and that's why the dealer went to the specialists at the HQ. Let us know what you learn, please.
 

Zuki1

Member
Local time
Yesterday, 16:26
Joined
Apr 15, 2021
Messages
4
Points
0
Age
49
Location
PNW
My Ride
Tiger 800 XCA
That's strange, and that's why the dealer went to the specialists at the HQ. Let us know what you learn, please.
I spoke with Triumph and they have now pushed the case to the electrical engineering team. They say they have received reports of this happening in other parts of the world. I guess they don't have a fix yet.
 

Greyfell

Proud Nerd
Riding for 4 Years
Local time
Yesterday, 16:26
Joined
May 4, 2016
Messages
2,799
Points
292
Age
64
Location
Northern California
First Name
Stephen
My Ride
2008 Triumph Bonneville T100 Ann-Margret
You and the dealer have probably checked this, but does your seat have a separate fuse that might be blown?
 

Charlie1780

Member
Riding for 44 Years
Local time
Today, 00:26
Joined
May 13, 2021
Messages
10
Points
7
Age
57
Location
Cannock, UK
First Name
Stewart
My Ride
Tiger 800
Scrambler 1200XE
I have spoken to the dealer, its a known problem but they are working on an update. Problem is your bike will need to go to the dealer to be updated, it cant be done through the app which is a shame.
As of today the update isn't ready.
 

Zuki1

Member
Local time
Yesterday, 16:26
Joined
Apr 15, 2021
Messages
4
Points
0
Age
49
Location
PNW
My Ride
Tiger 800 XCA
I have spoken to the dealer, its a known problem but they are working on an update. Problem is your bike will need to go to the dealer to be updated, it cant be done through the app which is a shame.
As of today the update isn't ready.
Thanks. Yes, I just heard from my dealer today. Sure hope it gets fixed soon as it also broke the fuel gauge which is also a known issue. They say the issues are only with the Tiger. I sure don't like to pay to become a software tester! :cry:
 

buddyrm

Member
Riding for 31 Years
Local time
Yesterday, 19:26
Joined
May 28, 2021
Messages
2
Points
0
Age
63
Location
Montreal
My Ride
Tiger 800 2018
Thanks. Yes, I just heard from my dealer today. Sure hope it gets fixed soon as it also broke the fuel gauge which is also a known issue. They say the issues are only with the Tiger. I sure don't like to pay to become a software tester! :cry:
My wife and I have each a 2018 tiger 800 and had the bluetooth system installed and we too have lost our heated seats, :-( I waited 24 months for this kit and now after installing it, the heated seats are broken, I would be very surprised if Triumph actually fixes this in the next few months, their track record is not very good. I too contact Triumph USA and issued a complaint. Lets see how it goes. I will also post if I hear any updates.
 

buddyrm

Member
Riding for 31 Years
Local time
Yesterday, 19:26
Joined
May 28, 2021
Messages
2
Points
0
Age
63
Location
Montreal
My Ride
Tiger 800 2018
Thanks. Yes, I just heard from my dealer today. Sure hope it gets fixed soon as it also broke the fuel gauge which is also a known issue. They say the issues are only with the Tiger. I sure don't like to pay to become a software tester! :cry:
I have the issue with the heated seat after the update, but I am not sure I understand about the fuel issue you mentioned. I see not problem after the update. Can you elaborate exactly what is the issue with the fuel gauge?
 

Zuki1

Member
Local time
Yesterday, 16:26
Joined
Apr 15, 2021
Messages
4
Points
0
Age
49
Location
PNW
My Ride
Tiger 800 XCA
I have the issue with the heated seat after the update, but I am not sure I understand about the fuel issue you mentioned. I see not problem after the update. Can you elaborate exactly what is the issue with the fuel gauge?
When I fill the tank completely, the gauge will not register anything. After I ride for a while, enough to where the gauge would drop down a bar, it will reappear. Very strange.
 
Premium

Support TriumphTalk by becoming a Premium Member.

 What You Get

Donate

 

 

Search

Top Bottom