Heated Seat Quit After Connectivity System Fitted.

buddyrm

Member
Riding for 31 Years
Local time
Today, 11:07
Joined
May 28, 2021
Messages
25
Points
7
Age
63
Location
Montreal
My Ride
Tiger 800 2018
The software update may have been done when it went in for servicing
Well one way to tell is has your menus and display format changed on your display, the software for the Bluetooth changed the look and feel of the display to more like the 2020 and 2021 models. So that you should have noticed. If it is still as it was when you bought it, then you do not have the update.
 

buddyrm

Member
Riding for 31 Years
Local time
Today, 11:07
Joined
May 28, 2021
Messages
25
Points
7
Age
63
Location
Montreal
My Ride
Tiger 800 2018
Well one way to tell is has your menus and display format changed on your display, the software for the Bluetooth changed the look and feel of the display to more like the 2020 and 2021 models. So that you should have noticed. If it is still as it was when you bought it, then you do not have the update.
Like this display
 

Charlie1780

Member
Riding for 44 Years
Local time
Today, 16:07
Joined
May 13, 2021
Messages
38
Points
7
Age
57
Location
Cannock, UK
First Name
Stewart
My Ride
Tiger 800
Scrambler 1200XE
That looks like one of the screen options, not the one i normally use but think thats one
of them
 

buddyrm

Member
Riding for 31 Years
Local time
Today, 11:07
Joined
May 28, 2021
Messages
25
Points
7
Age
63
Location
Montreal
My Ride
Tiger 800 2018
That looks like one of the screen options, not the one i normally use but think thats one
of them
Ok so it was updated, makes sense now with all the issues your having. The latest update does not fully fix the issues with heated seat or fuel gauge. But I was told that if you disconnect the Bluetooth module and have them update, it should put back the original software from the factory, then you can wait until a good update finally comes along, but I have serious doubts triumph will ever fix the issues properly. Super bad programmers and zero software quality testing, very disappointed at triumph support. Super bad.
 

neilh

Member
Riding for 31 Years
Local time
Today, 16:07
Joined
Aug 17, 2021
Messages
10
Points
7
Age
49
Location
Wolverhampton, UK
First Name
Neil
My Ride
Tiger 800XCA
Yeah I use that screen but in night mode, (it comes up black and gold and I am a Wolves FC fan so that works lol). Pretty sure thats only available after the connectivity module has been fitted.
 

neilh

Member
Riding for 31 Years
Local time
Today, 16:07
Joined
Aug 17, 2021
Messages
10
Points
7
Age
49
Location
Wolverhampton, UK
First Name
Neil
My Ride
Tiger 800XCA
Yeah I use that screen but in night mode, (it comes up black and gold and I am a Wolves FC fan so that works lol). Pretty sure thats only available after the connectivity module has been fitted.
Oh and one other thing mine has never had the fuel gauge problem even after the connectivity module. It has always took about 3 miles to settle down and show the right level after filling up, but apart from that fine.
 

buddyrm

Member
Riding for 31 Years
Local time
Today, 11:07
Joined
May 28, 2021
Messages
25
Points
7
Age
63
Location
Montreal
My Ride
Tiger 800 2018
Oh and one other thing mine has never had the fuel gauge problem even after the connectivity module. It has always took about 3 miles to settle down and show the right level after filling up, but apart from that fine.
What bike and year do you have? No heated seat issues?
 

LeBombardier

Member
Riding for 3 Years
Local time
Today, 16:07
Joined
Apr 19, 2019
Messages
4
Points
2
Age
31
Location
Cambridge, UK
First Name
Nathan
My Ride
Triumph Tiger 800 XRT 2018
Hey folks! Apologies for the delay in updating you on this - I had Triumph Suffolk (Ipswich) look into it on Friday. Apparently their entire Servicing Team didn't turn up that morning, so had to wait a while. They threw the bike into a diagnosis thingie where it detected new software for the module (at least), so updated it to the latest.

I can now get the rider seat to warm up. It does seem to cycle through off-medium-high (or vice versa, I forget the order). It's not obvious as it displays outline-red-red in colour, so no amber/yellow which you're used to seeing. I can definitely tell a clear temp difference between the two red icons, so suspect it's just a user interface bug rather than the digital switch.

The fuel gauge is still faulty once the tank has been filled up. It seems to not be based on the mileage you've done since filling up, but rather when you lose a segment/pip in capacity. So a full tank registers as completely empty rather than all the segments/pips being displayed. Weird!

So yep, Triumph need to get their act together and get this sorted. The app is completely useless, too. So silly things like being unable to talk with my pillion when both of our supported headsets are connected to the module. Instead we have to unpair them from the module and directly connect them up.

I've been on a 400 mile moto medic gig today on the Tiger and told everyone that's come up to the bike with interest never to buy a Triumph. They're not what they were...
 

Vector

Well-Known Member
Riding for 51 Years
Local time
Today, 08:07
Joined
Apr 10, 2020
Messages
331
Points
77
Location
NV
First Name
Gary
My Ride
2020 Vanderhall Venice Blackjack
Royal Enfield, Honda, Kawasaki, Harley, and others all have current recalls. Most electronics are crap these days, made in China garbage.
 

buddyrm

Member
Riding for 31 Years
Local time
Today, 11:07
Joined
May 28, 2021
Messages
25
Points
7
Age
63
Location
Montreal
My Ride
Tiger 800 2018
Hey folks! Apologies for the delay in updating you on this - I had Triumph Suffolk (Ipswich) look into it on Friday. Apparently their entire Servicing Team didn't turn up that morning, so had to wait a while. They threw the bike into a diagnosis thingie where it detected new software for the module (at least), so updated it to the latest.

I can now get the rider seat to warm up. It does seem to cycle through off-medium-high (or vice versa, I forget the order). It's not obvious as it displays outline-red-red in colour, so no amber/yellow which you're used to seeing. I can definitely tell a clear temp difference between the two red icons, so suspect it's just a user interface bug rather than the digital switch.

The fuel gauge is still faulty once the tank has been filled up. It seems to not be based on the mileage you've done since filling up, but rather when you lose a segment/pip in capacity. So a full tank registers as completely empty rather than all the segments/pips being displayed. Weird!

So yep, Triumph need to get their act together and get this sorted. The app is completely useless, too. So silly things like being unable to talk with my pillion when both of our supported headsets are connected to the module. Instead we have to unpair them from the module and directly connect them up.

I've been on a 400 mile moto medic gig today on the Tiger and told everyone that's come up to the bike with interest never to buy a Triumph. They're not what they were...
Yup really sad. I have 2 tiger 800's, one for me and one for my wife and we are so discouraged. Triumph USA won't even return my emails anymore trying to resolve this. Apparently removing the module and reconnecting the triumph service laptop will reverse the software and revert back to original factory software. I have been trying to confirm this with my dealer and even they have not returned my calls with an update if this is true or not. I have not seen such lack of support from a manufacture. Super sad. I am still waiting and will post an update once I get some info from the dealer or Triumph USA. But have been struggling to get this issue resolved since the spring and highly doubt it will ever get resolved.
 

neilh

Member
Riding for 31 Years
Local time
Today, 16:07
Joined
Aug 17, 2021
Messages
10
Points
7
Age
49
Location
Wolverhampton, UK
First Name
Neil
My Ride
Tiger 800XCA
What bike and year do you have? No heated seat issues?
Sorry yes it was in my earlier comment that i do have the heated seat issue, but never the fuel gauge issue, or any other issues - just the seat!
 

neilh

Member
Riding for 31 Years
Local time
Today, 16:07
Joined
Aug 17, 2021
Messages
10
Points
7
Age
49
Location
Wolverhampton, UK
First Name
Neil
My Ride
Tiger 800XCA
Sorry yes it was in my earlier comment that i do have the heated seat issue, but never the fuel gauge issue, or any other issues - just the seat!
and i still forgot to answer your question! 2018 xca
 

buddyrm

Member
Riding for 31 Years
Local time
Today, 11:07
Joined
May 28, 2021
Messages
25
Points
7
Age
63
Location
Montreal
My Ride
Tiger 800 2018
and i still forgot to answer your question! 2018 xca
OK strange, I have a 2018 XCA and my wife 2018 XRT and we both have the fuel issue. When we fill up full, the gauge goes full and then within 3 seconds rolls down to zero bars and stays like that for 65-70km before showing full minus one bar. So weird and all but you has that issue. not sure why you do not have it or maybe you have not noticed after a fill up.
 

neilh

Member
Riding for 31 Years
Local time
Today, 16:07
Joined
Aug 17, 2021
Messages
10
Points
7
Age
49
Location
Wolverhampton, UK
First Name
Neil
My Ride
Tiger 800XCA
OK strange, I have a 2018 XCA and my wife 2018 XRT and we both have the fuel issue. When we fill up full, the gauge goes full and then within 3 seconds rolls down to zero bars and stays like that for 65-70km before showing full minus one bar. So weird and all but you has that issue. not sure why you do not have it or maybe you have not noticed after a fill up.
Yeah it is odd and I have looked out for it, but mine just takes a few miles to sort itself after a fill-up. Put it this way I live 6miles from work and my usual fill up is right over the road from work - always sorted itself out by the time I get home. Just want my heated seat back now it's getting to end of September!!
 

Charlie1780

Member
Riding for 44 Years
Local time
Today, 16:07
Joined
May 13, 2021
Messages
38
Points
7
Age
57
Location
Cannock, UK
First Name
Stewart
My Ride
Tiger 800
Scrambler 1200XE
UPDATE IS HERE AND IT WORKS !!!!!!

Yesterday i went into my Triumph dealer in Tamworth UK... a great bunch of guys to be fair, but when i filled with fuel last week i lost the fuel display on my 2021 Tiger 800 XRT.
I had already lost my heated front seat with the connectivity module and like everyone else was waiting for the update. I had just filled up with fuel 50 miles from home and immediately lost the display (i could see it but it was all greyed out) but it came back on about 1 mile from home, so i asked the dealer to take a look. He said he would plug it in and see if he could find a fault code. Approx an hour later he said that no faults were found, HOWEVER, there was an update for the bikes software so he had installed that anyway. I joked that maybe it has fixed the seat issue to which he replied that Triumph haven't told them of any fix for the seat issue as yet.

I went out to the bike and started it up and checked the seat... and it worked!!!!! i told the guys the update had fixed the issue so everyone was happy and they said they would feed the news back to the factory. HOWEVER (again) when i got home i checked the bluetooth module and found that i couldn't pair with it.. nothing worked at all... so ... i called the dealer again this morning and said I had lost all connectivity to the bike and I would rather have the module working as i am going away for a week in October, than have the heated seat, so i took it over again this afternoon and the reinstalled the bluetooth software and guess what... everything works, all navigation functions etc AND THE HEATED SEAT !!!

So i f you still have no heated seat after installing the module , get down to your dealer, the update is out and it works.... but make sure they reinstall the bluetooth software AFTER they have updated the bike software.

Everything works as it should have done 12 months ago when i had the module installed... even the dealers have not been informed of this and now my local dealer knows he is calling is other customers with the same problem to get them booked in...... a good bike day today :cool:XRT 800.jpg
 

Charlie1780

Member
Riding for 44 Years
Local time
Today, 16:07
Joined
May 13, 2021
Messages
38
Points
7
Age
57
Location
Cannock, UK
First Name
Stewart
My Ride
Tiger 800
Scrambler 1200XE
UPDATE IS HERE AND IT WORKS !!!!!!

Yesterday i went into my Triumph dealer in Tamworth UK... a great bunch of guys to be fair, but when i filled with fuel last week i lost the fuel display on my 2021 Tiger 800 XRT.
I had already lost my heated front seat with the connectivity module and like everyone else was waiting for the update. I had just filled up with fuel 50 miles from home and immediately lost the display (i could see it but it was all greyed out) but it came back on about 1 mile from home, so i asked the dealer to take a look. He said he would plug it in and see if he could find a fault code. Approx an hour later he said that no faults were found, HOWEVER, there was an update for the bikes software so he had installed that anyway. I joked that maybe it has fixed the seat issue to which he replied that Triumph haven't told them of any fix for the seat issue as yet.

I went out to the bike and started it up and checked the seat... and it worked!!!!! i told the guys the update had fixed the issue so everyone was happy and they said they would feed the news back to the factory. HOWEVER (again) when i got home i checked the bluetooth module and found that i couldn't pair with it.. nothing worked at all... so ... i called the dealer again this morning and said I had lost all connectivity to the bike and I would rather have the module working as i am going away for a week in October, than have the heated seat, so i took it over again this afternoon and the reinstalled the bluetooth software and guess what... everything works, all navigation functions etc AND THE HEATED SEAT !!!

So i f you still have no heated seat after installing the module , get down to your dealer, the update is out and it works.... but make sure they reinstall the bluetooth software AFTER they have updated the bike software.

Everything works as it should have done 12 months ago when i had the module installed... even the dealers have not been informed of this and now my local dealer knows he is calling is other customers with the same problem to get them booked in...... a good bike day today :cool:
XRT 800.jpg
 

buddyrm

Member
Riding for 31 Years
Local time
Today, 11:07
Joined
May 28, 2021
Messages
25
Points
7
Age
63
Location
Montreal
My Ride
Tiger 800 2018
UPDATE IS HERE AND IT WORKS !!!!!!

Yesterday i went into my Triumph dealer in Tamworth UK... a great bunch of guys to be fair, but when i filled with fuel last week i lost the fuel display on my 2021 Tiger 800 XRT.
I had already lost my heated front seat with the connectivity module and like everyone else was waiting for the update. I had just filled up with fuel 50 miles from home and immediately lost the display (i could see it but it was all greyed out) but it came back on about 1 mile from home, so i asked the dealer to take a look. He said he would plug it in and see if he could find a fault code. Approx an hour later he said that no faults were found, HOWEVER, there was an update for the bikes software so he had installed that anyway. I joked that maybe it has fixed the seat issue to which he replied that Triumph haven't told them of any fix for the seat issue as yet.

I went out to the bike and started it up and checked the seat... and it worked!!!!! i told the guys the update had fixed the issue so everyone was happy and they said they would feed the news back to the factory. HOWEVER (again) when i got home i checked the bluetooth module and found that i couldn't pair with it.. nothing worked at all... so ... i called the dealer again this morning and said I had lost all connectivity to the bike and I would rather have the module working as i am going away for a week in October, than have the heated seat, so i took it over again this afternoon and the reinstalled the bluetooth software and guess what... everything works, all navigation functions etc AND THE HEATED SEAT !!!

So i f you still have no heated seat after installing the module , get down to your dealer, the update is out and it works.... but make sure they reinstall the bluetooth software AFTER they have updated the bike software.

Everything works as it should have done 12 months ago when i had the module installed... even the dealers have not been informed of this and now my local dealer knows he is calling is other customers with the same problem to get them booked in...... a good bike day today :cool:
XRT 800.jpg
I have a appointment on sept 27th. I will take this info to them and see what happens. I will ask them to do the steps you mentioned. Thanks for the update. Lets hope it works for me.
 

Charlie1780

Member
Riding for 44 Years
Local time
Today, 16:07
Joined
May 13, 2021
Messages
38
Points
7
Age
57
Location
Cannock, UK
First Name
Stewart
My Ride
Tiger 800
Scrambler 1200XE
I have a appointment on sept 27th. I will take this info to them and see what happens. I will ask them to do the steps you mentioned. Thanks for the update. Lets hope it works for me.
Good luck
 

neilh

Member
Riding for 31 Years
Local time
Today, 16:07
Joined
Aug 17, 2021
Messages
10
Points
7
Age
49
Location
Wolverhampton, UK
First Name
Neil
My Ride
Tiger 800XCA
UPDATE IS HERE AND IT WORKS !!!!!!

Yesterday i went into my Triumph dealer in Tamworth UK... a great bunch of guys to be fair, but when i filled with fuel last week i lost the fuel display on my 2021 Tiger 800 XRT.
I had already lost my heated front seat with the connectivity module and like everyone else was waiting for the update. I had just filled up with fuel 50 miles from home and immediately lost the display (i could see it but it was all greyed out) but it came back on about 1 mile from home, so i asked the dealer to take a look. He said he would plug it in and see if he could find a fault code. Approx an hour later he said that no faults were found, HOWEVER, there was an update for the bikes software so he had installed that anyway. I joked that maybe it has fixed the seat issue to which he replied that Triumph haven't told them of any fix for the seat issue as yet.

I went out to the bike and started it up and checked the seat... and it worked!!!!! i told the guys the update had fixed the issue so everyone was happy and they said they would feed the news back to the factory. HOWEVER (again) when i got home i checked the bluetooth module and found that i couldn't pair with it.. nothing worked at all... so ... i called the dealer again this morning and said I had lost all connectivity to the bike and I would rather have the module working as i am going away for a week in October, than have the heated seat, so i took it over again this afternoon and the reinstalled the bluetooth software and guess what... everything works, all navigation functions etc AND THE HEATED SEAT !!!

So i f you still have no heated seat after installing the module , get down to your dealer, the update is out and it works.... but make sure they reinstall the bluetooth software AFTER they have updated the bike software.

Everything works as it should have done 12 months ago when i had the module installed... even the dealers have not been informed of this and now my local dealer knows he is calling is other customers with the same problem to get them booked in...... a good bike day today :cool:View attachment 50975
Brilliant news - and guess what, my dealer is also the one in Tamworth, and you are right they really are a good bunch of guys.
 
Premium

Support TriumphTalk by becoming a Premium Member.

 What You Get

Donate

 

 

Search

Top Bottom