Help With Sprint Gt Electrical Issues Please

CRK23

Member
Local time
Tomorrow, 04:59
Joined
Dec 13, 2016
Messages
4
Points
0
Age
47
Location
Australia
First Name
Craig
My Ride
2012 Sprint GT
  1. Hi All,

    I need help please you see I have a slight little problem with my bike and it doesn't seem to want to be helpful and start.

    Problem
    I just replaced the Stator and upgraded the Reg Rectifier (mosfet tech one) and now the bike doesn't want to start.
    When I switch the ignition on, the lights and all gauges turn on, the fuel system does its run through and everything seems fine. I have noticed that the fuel gauge is not indicating fuel now, and when I hit the starter button, all the lights dip, all the gauges disappear and the bike makes no noise at all.

    Does anyone have a idea where I can start looking at fixing this problem as I so wanna get back out on the road.

    Thank You in Advance

    Craig
 

triumph david

Riding for 60 Years
Staff
Local time
Today, 11:59
Joined
Nov 25, 2013
Messages
5,208
Points
355
Age
72
Location
brookhaven
First Name
david
My Ride
1976 t140 Triumph, 2006 Road King, 1982 Honda CB 900 C, 1973 Yamaha 360 Enduro, 1972 Corbin
Probably something is "crossed" up in the wiring, get a diagram of the electrical layout and trace it out, also disconnect the reg. rect. and see what happens, then try the stator and see what happens. Are any limit switches at fault, or on/off? Try putting everything back like it was before and see what happens. Just a few things to try to get you back on the road, the thing about elect. is that you can't see it and it is always trying to test your temper. Good luck.
 
Premium

Support TriumphTalk by becoming a Premium Member.

 What You Get

Donate

 

 

Top Bottom