No Pressure After Clutch Change.

Benji

Member
Riding for 2 Years
Local time
Today, 19:48
Joined
May 27, 2021
Messages
2
Points
0
Age
33
Location
Sweden
First Name
Benjamin
My Ride
Tiger 1050
Hello guys and gals,

I hope you are doing alright . The season is turning here in Sweden, trying to catch the last day of driving. :)

Anyway, got to work on my tiger 1050 this weekend, I changed my clutch discs. But I ran into a problem and hoped someone here knew anything about it.
Everything went well until I put on my clutch cable and trying to tighten it, I don't get any resistance. No stretch at all. It's like a dead fish.

I borrowed someone on YouTube picture to try to help me explain it, atm I can't take any pictures. :(
Picture one is on the clutch house and disc.
Picture two is with the clutch cover on. The red ring is where my problem is (clutch cable).

When I try to tighten my clutch nothing happens, no resistance. I can't understand what I did wrong. All guides I look at and read tells me I've done it right. But somehow it refuses to pressure and give me some resistence.
I hope someone here could enlighten me, I don't dare to fill it with oil and start it.

I wish you all the best and I hope you had a great weekend :)

best wishes

Benjamin, Sweden.
 

Attachments

  • bild 1.png
    bild 1.png
    809.1 KB · Views: 3
  • bild 1.png
    bild 1.png
    809.1 KB · Views: 3
  • bild 2.png
    bild 2.png
    836.3 KB · Views: 3

sikatri

Well-Known Member
Local time
Today, 12:48
Joined
May 25, 2019
Messages
1,365
Points
122
Age
61
Location
Houston
My Ride
2005 Triumph Thruxton 900
Have you done clutch cable adjustments at both the lever and at the engine? Your old clutch would have needed the cable to be adjusted to work as it wore. Chances are you just need to do a full clutch cable adjustment. Do fill your engine with oil prior to adjustment.
 
Last edited:
Premium

Support TriumphTalk by becoming a Premium Member.

 What You Get

Donate

 

 

Search

Top Bottom