Sprint 1050 ST Won't start

Dotcy

Member
Riding for 34 Years
Local time
Today, 02:31
Joined
Aug 12, 2019
Messages
5
Points
0
Age
58
Location
Seattle
First Name
Dotcy
My Ride
1995 Sprint ST
Hi. Recently it takes more attempts to start the bike (5-7 tries), so much that at times battery drains. Once started it's fine, but even when warm it needed 2-3 tries. Now it turns and gives a "whacking" sound but won't start at all. I don't think it's the starter since it turns plenty and fast. Help?
 

Greyfell

Proud Nerd
Riding for 2 Years
Local time
Today, 02:31
Joined
May 4, 2016
Messages
1,476
Points
122
Age
62
Location
Northern California
First Name
Stephen
My Ride
2008 Triumph Bonneville T100 Ann-Margret
How old is the battery? Do you keep a battery tender on it when you have it in the garage?
 

Dotcy

Member
Riding for 34 Years
Local time
Today, 02:31
Joined
Aug 12, 2019
Messages
5
Points
0
Age
58
Location
Seattle
First Name
Dotcy
My Ride
1995 Sprint ST
How old is the battery? Do you keep a battery tender on it when you have it in the garage?
The battery is 2 years old and on a tender when not being ridden (winter.) The battery is strong for starting, most recently being jumped from my car, so not a battery issue (I believe.)
 

Greyfell

Proud Nerd
Riding for 2 Years
Local time
Today, 02:31
Joined
May 4, 2016
Messages
1,476
Points
122
Age
62
Location
Northern California
First Name
Stephen
My Ride
2008 Triumph Bonneville T100 Ann-Margret
Well, that was the first thing to check off the list. Up in Washington, 2 years is still young. Down in Arizona or Texas, 2 years is middle-aged. Heat ages batteries fast.
 

CarlS

Big Kahuna
Riding for 61 Years
Staff
Local time
Today, 05:31
Joined
Jan 5, 2006
Messages
25,120
Points
1,028
Age
75
Location
Altamonte Springs, Florida
First Name
Carl
My Ride
12 Tiger 800 XC
Check your battery terminal connections and make sure they are tight. If you van get to it, also chect your starter connection.
 

Dotcy

Member
Riding for 34 Years
Local time
Today, 02:31
Joined
Aug 12, 2019
Messages
5
Points
0
Age
58
Location
Seattle
First Name
Dotcy
My Ride
1995 Sprint ST
Check your battery terminal connections and make sure they are tight. If you van get to it, also chect your starter connection.
Thank you. I'll go there. After some more reading, the noise make me think its a sprag issue. I'll have to remove that cover and look at the gears.
 

Triumphlove

Member
Riding for 3 Years
Local time
Today, 05:31
Joined
Apr 1, 2019
Messages
7
Points
0
Age
48
Location
RHODE Island
First Name
Rene
My Ride
2006 sprint st 1050
Hi. Recently it takes more attempts to start the bike (5-7 tries), so much that at times battery drains. Once started it's fine, but even when warm it needed 2-3 tries. Now it turns and gives a "whacking" sound but won't start at all. I don't think it's the starter since it turns plenty and fast. Help?
Check stater or regulator rectifier?
 
Premium

Support TriumphTalk by becoming a Premium Member.

 What You Get

Donate

 

Top Bottom