Throttle Body Bal Help

dscshooter

Member
Local time
Yesterday, 21:34
Joined
Jul 20, 2016
Messages
4
Points
2
Age
45
Location
USA, Kentucky
First Name
Dennis
My Ride
2015 Speed Triple
image.png Ive noticed some rough idling and hooked up dealertool to view throttle body readings. Numbers 1 and 3 were balanced together but 2 was way off; 67-58-67. Removed the airbox and went to work. The best i could get is 65-57-65. I had the center adjuster nearly screwed all the way in. I experimented with many different ways to try to get them in synch. I checked all of the map hoses including the two going to cylinder 2 and they were all good. I then viewed the sensor readings with dealertool and attached those screenshots. Im curious about the fuel injectors. Looks like number 2 reads much lower. Any thoughts? 2015 Speed Triple
 

Attachments

  • image.png
    image.png
    41.2 KB · Views: 1
Last edited:

dscshooter

Member
Local time
Yesterday, 21:34
Joined
Jul 20, 2016
Messages
4
Points
2
Age
45
Location
USA, Kentucky
First Name
Dennis
My Ride
2015 Speed Triple
Its fixed!!! Sai hose was pushing up on map vac line to cyl 3. If you have a newer speed, id check this and push down on the sai hose and see if your kpa or mmhg changes.
 

Rocky

Still Rocking
Riding for 30 Years
Administrator
Staff
Local time
Yesterday, 22:34
Joined
Jan 28, 2006
Messages
20,426
Points
952
Age
85
Location
Halifax
First Name
Rocky
My Ride
2006 T100 Bonneville
TUP Glad to hear it as I had not the faintest idea how to help you BGRIN
 
Premium

Support TriumphTalk by becoming a Premium Member.

 What You Get

Donate

 

 

Search

Top Bottom